FrontSpin Server Issues
Incident Report for FrontSpin
Resolved
This incident has been resolved.
Posted Aug 15, 2023 - 12:15 UTC
Monitoring
The service is restored, but some users are still experiencing issue with emails. Our team continues to work on resolving the email issues.
Posted Aug 15, 2023 - 12:10 UTC
Investigating
FrontSpin is currently investigating the issue. Some users are reporting that they are unable to load some pages when logged in.
Posted Aug 15, 2023 - 07:07 UTC
This incident affected: FrontSpin App.