Back to overview
Resolved

Planned Maintenance - Downtime Expected

Aug 7, 2026 at 12:00am UTC  –  Aug 7, 2026 at 12:00am UTC
Affected services
Frontspin Page - Platform P2
Titanx Dialer - Login P2

Resolved
Aug 7, 2026 at 12:00am UTC

Maintenance ended

Created
Aug 7, 2026 at 12:00am UTC

Scheduled maintenance on https://p2.frontspin.com - August 7th, 12:00 AM UTC.