Back to overview
Resolved

Login issues for EU based users

Jul 13, 2026 at 8:03pm UTC
Affected services
Titanx Dialer - Login APP
Titanx Dialer - Login P2

Resolved
Jul 13, 2026 at 8:03pm UTC

we're investigating an issue related to login from EU