P2 Platform – Degraded Platform performance is impacting users' ability to use the P2 Platform.
Resolved
Jun 23, 2026 at 4:14pm UTC
All Frontspin systems are now operating as normal.
Please reach out to support@frontspin.com or support@titanx.io if you are continuing to experience any impacts.
We identified the root cause of the issues occurring on Frontspin's P2 instance and our team has made a fix. The Frontspin team is continuing to monitor our systems to ensure there are no further impacts to our clients.
Please note that following functionality was impacted on P2 during this from approximately 4:30am US ET through noon US ET:
- Call transcriptions
- Sending emails
- Password resets
- Phone number assignment
- Admin panel and settings
Affected services
Updated
Jun 23, 2026 at 2:22pm UTC
We working to implement a fix.
Please note that call transcriptions are currently unavailable on P2.
We will provide further updates soon.
Affected services
Created
Jun 23, 2026 at 1:17pm UTC
We are investigating processing delays on p2.frontspin.com that are impacting customers' ability to use the platform. We will provide updates as soon as possible.
Affected services