Back to overview

Calling issues US carrier

May 29, 2026 at 5:17pm UTC
Affected services
Frontspin Page - Platform APP
Frontspin Page - Platform P2
Frontspin Swagger Page - Public Api - Platform App
Frontspin Swagger Page - Public Api - Platform P2
Titanx Dialer - Login APP
Titanx Dialer - Login P2

Resolved
May 29, 2026 at 5:40pm UTC

Update: We identified an intermittent calling issue affecting our US carrier beginning at 1:04 PM EST. As of 1:30 PM EST, the issue appears to have resolved, but we are continuing to investigate with our carrier and will provide further updates as we have them.

We apologize for any disruption this may have caused. If you continue to experience issues, please reach out to support@titanx.io.

Created
May 29, 2026 at 5:17pm UTC

We are investigating an issue related to the inability to make calls using the US carrier. We will post another update in 15mins.
For any additional assistance, please reach out to support@titanx.io