Back to overview
Maintenance

Planned Maintenance - No Downtime

Apr 30, 2026 at 5:00pm UTC  –  Apr 30, 2026 at 5:20pm UTC
Affected services
Frontspin Page - Platform P2
Titanx Dialer - Login P2

Resolved
Apr 30, 2026 at 5:20pm UTC

Maintenance ended

Created
Apr 30, 2026 at 5:00pm UTC

Rolling out a configuration update to improve workflow reliability. No downtime expected.