Back to overview
Resolved
Calling unavailable on p2.frontspin.com
Sep 4, 2026 at 2:45pm UTC
Affected services
Frontspin Page - Platform P2
Titanx Dialer - Login P2
Resolved
Sep 4, 2026 at 3:08pm UTC
The Issue has been resolved. The team will continue to monitor the situation closely.
Affected services
Created
Sep 4, 2026 at 2:45pm UTC
Calling is currently unavailable on https://p2.frontspin.com. The platform itself is available and all other functions are working normally.
We are looking into it.
Affected services