Back to overview
Resolved

P2 is unavailable

Aug 29, 2026 at 2:05pm UTC
Affected services
Titanx Dialer - Login P2

Resolved
Aug 29, 2026 at 2:59pm UTC

P2 is available.

Created
Aug 29, 2026 at 2:05pm UTC

The team is aware and working at resolving the issue.